summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2010-11-04 13:12:12 -0400
committerColin Walters <walters@verbum.org>2010-11-09 13:56:43 -0500
commitf43f3a722323448dfce514a2b435390fd837ddee (patch)
treeebc3b6ebf329848a92d467b050ca8abf5e2e2daf /Makefile.am
parent2681a9dcb1182d8b0fc34fbb341d77a0a13c65f2 (diff)
downloadgobject-introspection-f43f3a722323448dfce514a2b435390fd837ddee.tar.gz
Switch to nonrecursive make for core (i.e. not tests/)
This is cleaner and faster, and prepares us better for an incoming import of CMPH.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 26 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 33df173c..1e111153 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,34 @@
+man_MANS =
+EXTRA_DIST =
+lib_LTLIBRARIES =
+noinst_LTLIBRARIES =
+BUILT_SOURCES =
+CLEANFILES = $(BUILT_SOURCES)
+INTROSPECTION_GIRS =
+check_LTLIBRARIES =
+check_PROGRAMS =
+bin_PROGRAMS =
+bin_SCRIPTS =
+noinst_PROGRAMS =
+
+include common.mk
+include Makefile.introspection
+
+include Makefile-girepository.am
+include Makefile-giscanner.am
+include Makefile-examples.am
+include Makefile-gir.am
+include Makefile-tools.am
+
## Process this file with automake to produce Makefile.in
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = girepository giscanner tools gir docs tests examples
+SUBDIRS = . docs tests
+
DIST_SUBDIRS = m4 $(SUBDIRS)
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
-man_MANS = \
+man_MANS += \
docs/g-ir-compiler.1 \
docs/g-ir-generate.1 \
docs/g-ir-scanner.1
@@ -19,7 +42,7 @@ m4_DATA = m4/introspection.m4
makedir = $(datadir)/gobject-introspection-1.0
dist_make_DATA = Makefile.introspection
-EXTRA_DIST = \
+EXTRA_DIST += \
COPYING.LGPL \
COPYING.GPL \
CONTRIBUTORS \