summaryrefslogtreecommitdiff
path: root/build/win32/vs9/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2014-01-20 16:30:22 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2014-01-20 16:30:22 +0800
commit39703440cfd4e7949708266270e447b7b22c9347 (patch)
treecfa236428be0cf0467ea9684fb19555339043c88 /build/win32/vs9/Makefile.am
parent9c2a45a635d9cd6ac752245be4af6d3f00212349 (diff)
downloadgobject-introspection-39703440cfd4e7949708266270e447b7b22c9347.tar.gz
Rework The Visual Studio 2008 Build Process
This patch makes the build of G-I on Visual Studio 2008 into a two-step process, as it would make it clearer and easier to the one building G-I by: -Splitting up the property sheets into multiple parts, where pre-configured code (which is currently shipped with the tarball) is copied using custom build steps, so that they can be re-copied when they are updated. This also removes the need for setting environment variables before launching the Visual Studio Project to build the G-I DLL, the tools written in C and the _giscanner Python2 module. The Python2 paths (set to Python 2.7.x) are now set in a property sheet, which can be updated quite easily, if needed. -Use a set of NMake Makefiles to build the introspection files for GLib, and also the .gir's that are shipped with G-I, and make it clear to people what things are needed to build the introspection files. -Standardizing across the board that we now use $(ApiVersion) for the .lib files and the "installation" of headers, etc. Similar updates to the Visual Studio 2010 files will follow later.
Diffstat (limited to 'build/win32/vs9/Makefile.am')
-rw-r--r--build/win32/vs9/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/build/win32/vs9/Makefile.am b/build/win32/vs9/Makefile.am
index ed82cbca..a385ce65 100644
--- a/build/win32/vs9/Makefile.am
+++ b/build/win32/vs9/Makefile.am
@@ -1,16 +1,19 @@
EXTRA_DIST = \
gobject-introspection.sln \
+ gi-build-defines.vsprops \
+ gi-extra-paths.vsprops \
+ gi-gen-srcs.vsprops \
+ gi-install.vspropsin \
+ gi-install.vsprops \
+ gi-version-paths.vsprops \
+ gi-prebuild.vcproj \
girepository.vcprojin \
- gir.vspropsin \
- gir.vsprops \
annotation.vcproj \
cmph-bdz-test.vcproj \
cmph.vcprojin \
- everything.vcproj \
foo.vcproj \
g-ir-compiler.vcprojin \
g-ir-generate.vcproj \
- generate_typelibs.vcproj \
gettype.vcproj \
gimarshallingtests.vcproj \
glib-print.vcproj \
@@ -23,8 +26,8 @@ EXTRA_DIST = \
_giscanner.vcproj \
README.txt
-gir.vsprops: $(top_srcdir)/build/win32/vs9/gir.vspropsin gir.vs9.install
- $(CPP) -P - <$(top_srcdir)/build/win32/vs9/gir.vspropsin >$@
+gi-install.vsprops: $(top_srcdir)/build/win32/vs9/gi-install.vspropsin gir.vs9.install
+ $(CPP) -P - <$(top_srcdir)/build/win32/vs9/gi-install.vspropsin >$@
rm gir.vs9.install
-CLEANFILES = gir.vsprops
+CLEANFILES = gir-install.vsprops