summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-07-29 17:33:22 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-29 18:57:03 +0200
commit77b1ca0d89006d63db5d5ffbb2da0fb4c260b248 (patch)
treeabd2b5a79cb63ed94cedc69fbd4cb3fcaa86f8ca /configure.ac
parent9535fc481f28fa661fa9d48b932e089aa3504bc3 (diff)
downloadgobject-introspection-77b1ca0d89006d63db5d5ffbb2da0fb4c260b248.tar.gz
build: enable -Wredundant-decls
The ffi decls were added in cbdd9ee09e367e4dd to work around broken ffi headers. Let's assume this is fixed now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index af2a27d0..78e500ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,14 +65,14 @@ AX_COMPILER_FLAGS(,, [yes])
# These get triggered a lot, not worth it imo, but feel free to fix them
AX_APPEND_COMPILE_FLAGS([-Wno-duplicated-branches -Wno-switch-enum])
# FIXME: Fix the warnings and remove the flags
-AX_APPEND_COMPILE_FLAGS([-Wno-redundant-decls -Wno-deprecated-declarations])
+AX_APPEND_COMPILE_FLAGS([-Wno-deprecated-declarations])
WARN_CFLAGS_PYTHON="$WARN_CFLAGS"
AX_APPEND_COMPILE_FLAGS([-Wno-discarded-qualifiers], [WARN_CFLAGS_PYTHON])
AC_SUBST(WARN_CFLAGS_PYTHON)
WARN_CFLAGS_FLEX="$WARN_CFLAGS"
-AX_APPEND_COMPILE_FLAGS([-Wno-sign-compare -Wno-switch-default], [WARN_CFLAGS_FLEX])
+AX_APPEND_COMPILE_FLAGS([-Wno-sign-compare -Wno-switch-default -Wno-redundant-decls], [WARN_CFLAGS_FLEX])
AC_SUBST(WARN_CFLAGS_FLEX)
# Checks for libraries.