summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-06-21 10:12:50 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-06-21 10:12:50 +0200
commit2d34d90fda8a96a9e37ae5f3fdd6900c6a388bfa (patch)
treea5939d345d77d3bf31de06077db30f5e3238a225 /configure.ac
parent8bcc831c5f80bdac44b360db5fbb16db118a6951 (diff)
downloadgobject-introspection-2d34d90fda8a96a9e37ae5f3fdd6900c6a388bfa.tar.gz
configure.ac: Don't hardcode the Python C-ext file extension
.pyd doesn't work with Python 3 on Windows, ask Python for what file extension it expects instead of hardcoding it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fd1347f5..982d9038 100644
--- a/configure.ac
+++ b/configure.ac
@@ -278,6 +278,9 @@ if test "x$os_win32" = "xyes"; then
AM_CHECK_PYTHON_LIBS(, AC_MSG_ERROR([Python libs not found. Windows requires Python modules to be explicitly linked to libpython.]))
fi
+PYTHON_SO=`$PYTHON -c "import sysconfig, sys; get = sysconfig.get_config_var; sys.stdout.write(get('EXT_SUFFIX') or get('SO') or '.so');"`
+AC_SUBST(PYTHON_SO)
+
dnl Not enabled by default until 3.6 cycle when we can propose mako as
dnl an external dependency
AC_ARG_ENABLE(doctool,[ --disable-doctool disable g-ir-doc-tool ],,enable_doctool=auto)