summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-07-29 15:24:59 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-29 18:56:58 +0200
commit54e8b9b96e4553b4a05e95612d0a91677e85f9e8 (patch)
tree94cd99b3f91321b55bf33d015441efcf7e0fc55c /configure.ac
parent769f7602dc5762fe1df3c44a0dd2f2b2fcc39dd8 (diff)
downloadgobject-introspection-54e8b9b96e4553b4a05e95612d0a91677e85f9e8.tar.gz
build: enable -Wcast-function-type
Where it's easy add dummy args to match the cast; where the target is a subset just prevent the warning with a cast to void*. Provide a real copy function for the boxed type code in regress_foo. This code is never executed afaics, but why not.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 80475973..52536129 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,7 +65,7 @@ AX_COMPILER_FLAGS(,, [yes])
# These get triggered a lot, not worth it imo, but feel free to fix them
AX_APPEND_COMPILE_FLAGS([-Wno-duplicated-branches -Wno-switch-enum])
# FIXME: Fix the warnings and remove the flags
-AX_APPEND_COMPILE_FLAGS([-Wno-redundant-decls -Wno-switch-default -Wno-shadow -Wno-deprecated-declarations -Wno-cast-function-type -Wno-type-limits])
+AX_APPEND_COMPILE_FLAGS([-Wno-redundant-decls -Wno-switch-default -Wno-shadow -Wno-deprecated-declarations -Wno-type-limits])
AX_APPEND_COMPILE_FLAGS([-Wno-implicit-fallthrough -Wno-sign-compare])
WARN_CFLAGS_PYTHON="$WARN_CFLAGS"