summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-07-29 17:13:16 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-29 18:57:03 +0200
commit9535fc481f28fa661fa9d48b932e089aa3504bc3 (patch)
tree1fe0475b815e59ac637d284ffdb70d34c38550b9 /configure.ac
parente552057558ac4c02b9bba922ee2f06d2f9b0d57d (diff)
downloadgobject-introspection-9535fc481f28fa661fa9d48b932e089aa3504bc3.tar.gz
build: enable -Wswitch-default
In case the surrounding code handles missing cases break, otherwise add a g_assert_not_reached(). The generated parser code triggers this as well, so disable it there only.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bfe7c5d8..af2a27d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,14 +65,14 @@ AX_COMPILER_FLAGS(,, [yes])
# These get triggered a lot, not worth it imo, but feel free to fix them
AX_APPEND_COMPILE_FLAGS([-Wno-duplicated-branches -Wno-switch-enum])
# FIXME: Fix the warnings and remove the flags
-AX_APPEND_COMPILE_FLAGS([-Wno-redundant-decls -Wno-switch-default -Wno-deprecated-declarations])
+AX_APPEND_COMPILE_FLAGS([-Wno-redundant-decls -Wno-deprecated-declarations])
WARN_CFLAGS_PYTHON="$WARN_CFLAGS"
AX_APPEND_COMPILE_FLAGS([-Wno-discarded-qualifiers], [WARN_CFLAGS_PYTHON])
AC_SUBST(WARN_CFLAGS_PYTHON)
WARN_CFLAGS_FLEX="$WARN_CFLAGS"
-AX_APPEND_COMPILE_FLAGS([-Wno-sign-compare], [WARN_CFLAGS_FLEX])
+AX_APPEND_COMPILE_FLAGS([-Wno-sign-compare -Wno-switch-default], [WARN_CFLAGS_FLEX])
AC_SUBST(WARN_CFLAGS_FLEX)
# Checks for libraries.