summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-12-07 00:05:26 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-12-07 00:05:26 +0100
commit86b42e633c7679d97e7844ecec4c7783c6aedff0 (patch)
treef1ab886d10476ee0afd8df36286d02060bc927eb /configure.ac
parentdee930c5e5b55a51c37e95f43cb9dbf1b5d760fb (diff)
downloadgobject-introspection-86b42e633c7679d97e7844ecec4c7783c6aedff0.tar.gz
autotools: Replace AS_AC_EXPAND with AX_RECURSIVE_EVAL
It's part of autoconf-archive and lets us drop the acinclude.m4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 31206f36..469ca9cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,12 +97,12 @@ AC_DEFINE_UNQUOTED([SHLIB_SUFFIX], "$SHLIB_SUFFIX", [Define to the platform's sh
#### find the actual value for $prefix that we'll end up with
## (I know this is broken and should be done in the Makefile, but
## that's a major pain and almost nobody actually seems to care)
-AS_AC_EXPAND(EXPANDED_LOCALSTATEDIR, "$localstatedir")
-AS_AC_EXPAND(EXPANDED_SYSCONFDIR, "$sysconfdir")
-AS_AC_EXPAND(EXPANDED_BINDIR, "$bindir")
-AS_AC_EXPAND(EXPANDED_LIBDIR, "$libdir")
-AS_AC_EXPAND(EXPANDED_LIBEXECDIR, "$libexecdir")
-AS_AC_EXPAND(EXPANDED_DATADIR, "$datadir")
+AX_RECURSIVE_EVAL([$localstatedir], EXPANDED_LOCALSTATEDIR)
+AX_RECURSIVE_EVAL([$sysconfdir], EXPANDED_SYSCONFDIR)
+AX_RECURSIVE_EVAL([$bindir], EXPANDED_BINDIR)
+AX_RECURSIVE_EVAL([$libdir], EXPANDED_LIBDIR)
+AX_RECURSIVE_EVAL([$libexecdir], EXPANDED_LIBEXECDIR)
+AX_RECURSIVE_EVAL([$datadir], EXPANDED_DATADIR)
#### Directory to install the libexec binaries
GOBJECT_INTROSPECTION_LIBDIR="$EXPANDED_LIBDIR"