summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-12-08 15:54:53 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-12-08 15:54:53 +0100
commit7c770ea4bbd0ddbb4f97551d05e884af4a9f8b21 (patch)
treefba696b06fd7710ee56931722b3733da87db8895 /configure.ac
parent0bd5eb63e07d0492a123ada35356e2f02e3467e1 (diff)
downloadgobject-introspection-7c770ea4bbd0ddbb4f97551d05e884af4a9f8b21.tar.gz
Revert "autotools: Replace AS_AC_EXPAND with AX_RECURSIVE_EVAL"
This reverts commit 86b42e633c7679d97e7844ecec4c7783c6aedff0.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 469ca9cc..31206f36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,12 +97,12 @@ AC_DEFINE_UNQUOTED([SHLIB_SUFFIX], "$SHLIB_SUFFIX", [Define to the platform's sh
#### find the actual value for $prefix that we'll end up with
## (I know this is broken and should be done in the Makefile, but
## that's a major pain and almost nobody actually seems to care)
-AX_RECURSIVE_EVAL([$localstatedir], EXPANDED_LOCALSTATEDIR)
-AX_RECURSIVE_EVAL([$sysconfdir], EXPANDED_SYSCONFDIR)
-AX_RECURSIVE_EVAL([$bindir], EXPANDED_BINDIR)
-AX_RECURSIVE_EVAL([$libdir], EXPANDED_LIBDIR)
-AX_RECURSIVE_EVAL([$libexecdir], EXPANDED_LIBEXECDIR)
-AX_RECURSIVE_EVAL([$datadir], EXPANDED_DATADIR)
+AS_AC_EXPAND(EXPANDED_LOCALSTATEDIR, "$localstatedir")
+AS_AC_EXPAND(EXPANDED_SYSCONFDIR, "$sysconfdir")
+AS_AC_EXPAND(EXPANDED_BINDIR, "$bindir")
+AS_AC_EXPAND(EXPANDED_LIBDIR, "$libdir")
+AS_AC_EXPAND(EXPANDED_LIBEXECDIR, "$libexecdir")
+AS_AC_EXPAND(EXPANDED_DATADIR, "$datadir")
#### Directory to install the libexec binaries
GOBJECT_INTROSPECTION_LIBDIR="$EXPANDED_LIBDIR"