summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-12-14 11:21:29 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-12-16 12:51:58 +0100
commit9c339f8b0d73c3475edeab37c52dbf991f67b7fa (patch)
tree0b87aeb20b2b8f17076d90510b68f1d02410891a /configure.ac
parentc0dd66c3f6cf25404124b5a4d2e49f5cdc9b7110 (diff)
downloadgobject-introspection-9c339f8b0d73c3475edeab37c52dbf991f67b7fa.tar.gz
girepository: Add version macros and functions. Fixes #200
This adds the following macros and functions: GI_MAJOR_VERSION, GI_MICRO_VERSION, GI_MINOR_VERSION, GI_CHECK_VERSION, gi_get_major_version,gi_get_micro_version, gi_get_minor_version. Since we share a prefix with glib we have to namespace these by using the gi_ prefix. g_gi would also work but we already export symbols with gi_ like gi_cclosure_marshal_generic(), gi_type_tag_get_ffi_type() and gi_type_info_extract_ffi_return_value(), so let's not add another naming scheme.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31206f36..b6a0952a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,13 @@ AM_SILENT_RULES([yes])
GI_VERSION=gi_version
AC_SUBST(GI_VERSION)
+GI_MAJOR_VERSION=gi_major_version
+GI_MINOR_VERSION=gi_minor_version
+GI_MICRO_VERSION=gi_micro_version
+AC_SUBST(GI_MAJOR_VERSION)
+AC_SUBST(GI_MINOR_VERSION)
+AC_SUBST(GI_MICRO_VERSION)
+
# Check for Win32
AC_CANONICAL_HOST
case "$host" in
@@ -388,6 +395,7 @@ docs/Makefile
docs/reference/Makefile
docs/reference/version.xml
giscanner/_version.py
+girepository/giversion.h
gobject-introspection-1.0.pc
gobject-introspection-no-export-1.0.pc])
AC_OUTPUT