summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-07-29 16:40:27 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-29 18:57:03 +0200
commite552057558ac4c02b9bba922ee2f06d2f9b0d57d (patch)
tree5bcd9d91896ba19014799730fe02f94ec05c85ca /configure.ac
parentfaa39ef9c9a2452df5caedecf1452ec262b2816b (diff)
downloadgobject-introspection-e552057558ac4c02b9bba922ee2f06d2f9b0d57d.tar.gz
build: enable -Wtype-limits
hashv is unsigned, no need to check if >= 0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a8482ca6..bfe7c5d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,7 +65,7 @@ AX_COMPILER_FLAGS(,, [yes])
# These get triggered a lot, not worth it imo, but feel free to fix them
AX_APPEND_COMPILE_FLAGS([-Wno-duplicated-branches -Wno-switch-enum])
# FIXME: Fix the warnings and remove the flags
-AX_APPEND_COMPILE_FLAGS([-Wno-redundant-decls -Wno-switch-default -Wno-deprecated-declarations -Wno-type-limits])
+AX_APPEND_COMPILE_FLAGS([-Wno-redundant-decls -Wno-switch-default -Wno-deprecated-declarations])
WARN_CFLAGS_PYTHON="$WARN_CFLAGS"
AX_APPEND_COMPILE_FLAGS([-Wno-discarded-qualifiers], [WARN_CFLAGS_PYTHON])