summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTommi Komulainen <tommi.komulainen@iki.fi>2008-11-01 18:21:55 +0000
committerTommi Komulainen <tko@src.gnome.org>2008-11-01 18:21:55 +0000
commit9cb013f03e6272381ff1ddd2e476e7a6ed8b9a09 (patch)
tree1cb9a9ace8442806a3dd55b9a489f915839f2f36 /configure.ac
parentfacfd21a6533e6666b6f18c708401ceca22458a2 (diff)
downloadgobject-introspection-9cb013f03e6272381ff1ddd2e476e7a6ed8b9a09.tar.gz
Bug 557898 – Fails to build on OSX 10.4
2008-11-01 Tommi Komulainen <tommi.komulainen@iki.fi> * configure.ac: Check for $shrext_cmds that should be implicitly available if you're using libtool >= 2.0. If undefined, call libtool --config explicitly to get its value. * girepository/gtypelib.c: Remove special case for (non-)Darwin systems as unneeded. svn path=/trunk/; revision=859
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 895b7f12..b5f009d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,15 +75,18 @@ GI_ENABLE_GCOV
AC_CHECK_LIB([dl], [dlopen])
AC_MSG_CHECKING(for the suffix of shared libraries)
-export SED
-shrext_cmds=`./libtool --config | grep '^shrext_cmds='`
-eval $shrext_cmds
+# libtool variables are immediately available since 2.0, prior to that we need
+# to call libtool --config explicitly
+if test "x$shrext_cmds" = x; then
+ shrext_cmds=`SED=$SED ./libtool --config | grep '^shrext_cmds='`
+ eval $shrext_cmds
+fi
eval std_shrext=$shrext_cmds
# chop the initial dot
-SHLIB_SUFFIX=`echo $std_shrext | sed 's/^\.//'`
+SHLIB_SUFFIX=${std_shrext#.}
AC_MSG_RESULT(.$SHLIB_SUFFIX)
# any reason it may fail?
-if test "X$SHLIB_SUFFIX" = x; then
+if test "x$SHLIB_SUFFIX" = x; then
AC_MSG_ERROR(Cannot determine shared library suffix from libtool)
fi
AC_DEFINE_UNQUOTED([SHLIB_SUFFIX], "$SHLIB_SUFFIX", [Define to the platform's shared library suffix])