summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohan Dahlin <johan@gnome.org>2008-03-25 21:47:47 +0000
committerJohan Dahlin <johan@src.gnome.org>2008-03-25 21:47:47 +0000
commita310fd859d42006253d8541f366ca458bdb09493 (patch)
tree777b485f61419a9c0ea04d002ce32251ed596bc2 /configure.ac
parent66ab1202b6499e030c32c9d0d3432e0b09bee7db (diff)
downloadgobject-introspection-a310fd859d42006253d8541f366ca458bdb09493.tar.gz
Add initial python bindings for the scanner and depend on python 2.5.
2008-03-25 Johan Dahlin <johan@gnome.org> * configure.ac: * giscanner: * giscanner/__init__.py: * giscanner/giscannermodule.c: * giscanner/Makefile.am: Add initial python bindings for the scanner and depend on python 2.5. svn path=/trunk/; revision=165
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ca163df..51d44f85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,12 @@ AC_C_CONST
AC_FUNC_STRTOD
AC_CHECK_FUNCS([memchr strchr strspn strstr strtol strtoull])
+# Python
+
+AC_MSG_CHECKING([whether Python support is requested])
+
+AM_PATH_PYTHON([2.5])
+AM_CHECK_PYTHON_HEADERS
AC_CONFIG_FILES([Makefile
gidl/Makefile