summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-02-21 10:41:52 -0500
committerColin Walters <walters@verbum.org>2012-02-21 10:43:45 -0500
commitbd983994b9a63639fda836a06f4102776b9e1480 (patch)
tree86c2b8fdee9ee5edd0a5a9562c4fe65dc42406bf /configure.ac
parentfc1c96b9ae52434da6df5d9d69a3593a2a30cb8a (diff)
downloadgobject-introspection-bd983994b9a63639fda836a06f4102776b9e1480.tar.gz
build: Add --enable-doctool option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c311f660..0b67b085 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,7 +272,11 @@ if test "x$os_win32" = "xyes"; then
AM_CHECK_PYTHON_LIBS(, AC_MSG_ERROR([Python libs not found. Windows requires Python modules to be explicitly linked to libpython.]))
fi
-AM_CHECK_PYMOD(mako,,,[AC_MSG_ERROR(Could not find python module: mako)])
+AC_ARG_ENABLE(doctool,[ --enable-doctool enable g-ir-doctool ], enable_doctool=$enableval,enable_doctool=no)
+if test x$enable_doctool != xno; then
+ AM_CHECK_PYMOD(mako,,,[AC_MSG_ERROR(Could not find python module: mako)])
+fi
+AM_CONDITIONAL(BUILD_DOCTOOL, test x$enable_doctool != xno)
# Glib documentation