summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohan Dahlin <jdahlin@litl.com>2009-02-20 23:32:26 -0300
committerJohan Dahlin <johan@gnome.org>2009-02-20 23:32:26 -0300
commitb877e24ced1a2c699e1aa9d37a998e0340d3b3f0 (patch)
tree85e58d3e06037fc8db9bbcbcefdd1914555e6c1d /configure.ac
parent1f024a1a2894448d37e91feb0b5a047f9ce55a96 (diff)
downloadgobject-introspection-b877e24ced1a2c699e1aa9d37a998e0340d3b3f0.tar.gz
Use shave to reduce compiling output
Which let's us focus on the important warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2996286d..c81b00ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,7 @@ if test "$YACC" = :; then
AC_MSG_ERROR([bison not found but required])
fi
+
changequote(,)dnl
ensureflag() {
flag="$1"; shift
@@ -190,6 +191,7 @@ case "$host" in
esac
AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
+SHAVE_INIT([scripts])
AC_CONFIG_FILES([
Makefile
gir/Makefile
@@ -197,6 +199,8 @@ girepository/Makefile
giscanner/Makefile
giscanner/config.py
m4/Makefile
+scripts/shave
+scripts/shave-libtool
tools/Makefile
tests/Makefile
tests/invoke/Makefile