summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2011-09-05 15:48:26 +0200
committerDieter Verfaillie <dieterv@optionexplicit.be>2011-09-07 21:37:39 +0200
commita8977bc6c93793fc9a2e9b6d4315c385d5ed4cb9 (patch)
tree4d4a48dfa4a28b057302c670da65b60cdc1aad79 /configure.ac
parent4b57f684dac03a57edcff0ee554883eab7f345b3 (diff)
downloadgobject-introspection-a8977bc6c93793fc9a2e9b6d4315c385d5ed4cb9.tar.gz
Windows port: Use an improved python.m4
- AM_CHECK_PYTHON_HEADERS macro now allows PYTHON_INCLUDES to be overridden from an environment variable and - the new AM_CHECK_PYTHON_LIBS macro to check for ability to link against libpython. This also allows PYTHON_LIBS and PYTHON_LIB_LOC to be overridden from their respective environment variables. This allows gobject-introspection to be built with MinGW/MSYS by doing: PYTHON_DIR="/c/Python27" SRC_DIR="/d/dev/gnome.org/checkout/gobject-introspection/src" ... PYTHON_INCLUDES="-I${PYTHON_DIR}/include/" \ PYTHON_LIBS="-L${PYTHON_DIR}/libs/ -lpython${PYTHON_VERSION}" \ PYTHON_LIB_LOC="${PYTHON_DIR}/libs/" \ "${SRC_DIR}/configure" \ https://bugzilla.gnome.org/show_bug.cgi?id=620566
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 570d7562..9e745b43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -248,9 +248,6 @@ AC_CHECK_FUNCS([memchr strchr strspn strstr strtol strtoull])
AC_CHECK_FUNCS([backtrace backtrace_symbols])
# Python
-
-AC_MSG_CHECKING([whether Python support is requested])
-
AM_PATH_PYTHON([2.5])
case "$host" in
*-*-mingw*)
@@ -259,7 +256,8 @@ case "$host" in
pyexecdir=`echo $pyexecdir | tr '\\\\' '/'`
;;
esac
-AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
+AM_CHECK_PYTHON_HEADERS(, AC_MSG_ERROR([Python headers not found]))
+AM_CHECK_PYTHON_LIBS(, AC_MSG_ERROR([Python libs not found]))
# Glib documentation