summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2011-09-17 13:30:28 +0200
committerDieter Verfaillie <dieterv@optionexplicit.be>2011-09-17 13:30:28 +0200
commit0a73abbd904150a3f97aae64be3974080af1ff2d (patch)
tree3337a7265b5471c6591932e39071cfc5f82c0acb /configure.ac
parent1e26aa4158d8e42a3cd2bed7d9fbf385e81e5fc8 (diff)
downloadgobject-introspection-0a73abbd904150a3f97aae64be3974080af1ff2d.tar.gz
Fix linking against libpython
- AM_CHECK_PYTHON_LIBS doesn't work for 64bit sytems (lib64) - Python extension modules do not need to be linked against libpython on linux anyway, but it is needed on Windows So only run AM_CHECK_PYTHON_LIBS in configure.ac for the windows case and make it clear in Makefile-giscanner.am linking against libpython is a windows only thing. https://bugzilla.gnome.org/show_bug.cgi?id=658914
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 75c0e4e5..c3f856e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,7 +32,7 @@ case "$host" in
os_win32=no
;;
esac
-AM_CONDITIONAL(OS_WIN32, [test x"$os_win32" = "xyes"])
+AM_CONDITIONAL(OS_WIN32, [test "x$os_win32" = "xyes"])
# Checks for programs.
AC_PROG_CC
@@ -261,7 +261,9 @@ case "$host" in
;;
esac
AM_CHECK_PYTHON_HEADERS(, AC_MSG_ERROR([Python headers not found]))
-AM_CHECK_PYTHON_LIBS(, AC_MSG_ERROR([Python libs not found]))
+if test "x$os_win32" = "xyes"; then
+ AM_CHECK_PYTHON_LIBS(, AC_MSG_ERROR([Python libs not found. Windows requires Python modules to be explicitly linked to libpython.]))
+fi
# Glib documentation