summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <jjardon@gnome.org>2012-09-26 01:17:07 +0900
committerJavier Jardón <jjardon@gnome.org>2012-09-27 00:09:24 +0900
commit62c67bcc35967a3628ff9c09f7c8c77144dd4b6d (patch)
tree2ccd4d4807da0880c094dfc285fc6670bcb5044d /configure.ac
parent460cef9cfab15523b453838fa7794d7a203564fc (diff)
downloadgobject-introspection-62c67bcc35967a3628ff9c09f7c8c77144dd4b6d.tar.gz
Make gtk-doc not a hard dependency of gobject-introspection
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=684795
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 28d6f146..775b50a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,7 +231,13 @@ GIREPO_CFLAGS="$GIREPO_CFLAGS $FFI_CFLAGS"
GIREPO_CFLAGS="$GIREPO_CFLAGS $GCOV_CFLAGS"
# gtk-doc
-GTK_DOC_CHECK([1.15],[--flavour no-tmpl])
+# gtkdocize greps for ^GTK_DOC_CHECK and parses it, so you need to have
+# it on it's own line.
+m4_ifdef([GTK_DOC_CHECK], [
+GTK_DOC_CHECK([1.15], [--flavour no-tmpl])
+],[
+AM_CONDITIONAL([ENABLE_GTK_DOC],[false])
+])
# Checks for header files.
AC_HEADER_STDC