summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Knowles <alan@akbkhome.com>2010-09-07 09:53:47 +0800
committerAlan Knowles <alan@akbkhome.com>2010-09-07 09:53:47 +0800
commit073fba57af9e1286fdfdf5a40e66a279eaa4c123 (patch)
tree3c04efad6f7f5ce65f2a4606bc8963811694b6ef /configure.ac
parent026ffeb48b6bbefb884408d48c9fc8d1292c3205 (diff)
downloadgobject-introspection-073fba57af9e1286fdfdf5a40e66a279eaa4c123.tar.gz
Enhancement #612253 - add configure --with-glib-src=PATH
This enables glib documentation to be added to the generated gir using the original source eg. --with-glib-src=/usr/src/glib
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c2d50475..5dfcee8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,6 +223,21 @@ case "$host" in
esac
AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
+# Glib documentation
+
+GLIBSRC=
+AC_MSG_CHECKING([for glib source directory to use for documentation])
+
+AC_ARG_WITH(glib-src,
+ [ --with-glib-src=PATH Source directory for glib - needed to add docs to gir],
+ GLIBSRC=$withval
+)
+AM_CONDITIONAL(WITH_GLIBSRC, test x"$GLIBSRC" != x)
+AC_SUBST(GLIBSRC)
+AC_MSG_RESULT([$GLIBSRC])
+
+
+
AC_CONFIG_FILES([
Makefile
gir/Makefile