summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-02-15 13:56:15 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2017-02-15 13:56:15 +0800
commitef339c69f190973a149a4932c0c4800b447d3e11 (patch)
treee047227b415ac4f63f323a489ab280f0059b6b39 /configure.ac
parent579a018cf5fa64e73946db0788ea236d402c3a00 (diff)
downloadgobject-introspection-ef339c69f190973a149a4932c0c4800b447d3e11.tar.gz
Visual Studio builds: Support Visual Studio 2017
... in the projects for now, the NMake Makefiles for the introspection files (.gir/.typelib) need to be updated as well, but that needs to be done a bit later. This is done by updating the autotools scripts, so that the Visual Studio 2010 projects are copied and the items are updated as necessary. Note that since the format of the platform toolset changed for Visual Studio 2017, a custom platform toolset string is allowed and used if specified, otherwise the platform toolset string is generated as it was before.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 31713479..523d57b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -360,6 +360,12 @@ fi
AC_SUBST(EXTRA_LINK_FLAGS)
+dnl
+dnl Check whether MSVC toolset is explicitly set
+dnl
+AM_CONDITIONAL(MSVC_BASE_NO_TOOLSET_SET, [test x$MSVC_BASE_TOOLSET = x])
+AM_CONDITIONAL(MSVC_NO_TOOLSET_SET, [test x$MSVC_TOOLSET = x])
+
AC_CONFIG_FILES([
Makefile
tests/Makefile
@@ -381,5 +387,6 @@ win32/vs10/Makefile
win32/vs10/gi-version-paths.props
win32/vs11/Makefile
win32/vs12/Makefile
-win32/vs14/Makefile])
+win32/vs14/Makefile
+win32/vs15/Makefile])
AC_OUTPUT