summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Walters <walters@src.gnome.org>2008-10-25 14:59:25 +0000
committerColin Walters <walters@src.gnome.org>2008-10-25 14:59:25 +0000
commitc7d2a0712f6301aa670f87a98e8f217bf3c54a7a (patch)
tree8db4312a7c674b1193e42a7bc264d9ea864eb929 /configure.ac
parent6b8c119d1338080ccc254bb48d99c721dd937cdb (diff)
downloadgobject-introspection-c7d2a0712f6301aa670f87a98e8f217bf3c54a7a.tar.gz
Bug 557076 - move typelibs to $libdir
svn path=/trunk/; revision=813
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5202bdcf..b7de3976 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,6 +88,22 @@ if test "X$SHLIB_SUFFIX" = x; then
fi
AC_DEFINE_UNQUOTED([SHLIB_SUFFIX], "$SHLIB_SUFFIX", [Define to the platform's shared library suffix])
+# Copied from dbus configure.in
+#### find the actual value for $prefix that we'll end up with
+## (I know this is broken and should be done in the Makefile, but
+## that's a major pain and almost nobody actually seems to care)
+AS_AC_EXPAND(EXPANDED_LOCALSTATEDIR, "$localstatedir")
+AS_AC_EXPAND(EXPANDED_SYSCONFDIR, "$sysconfdir")
+AS_AC_EXPAND(EXPANDED_BINDIR, "$bindir")
+AS_AC_EXPAND(EXPANDED_LIBDIR, "$libdir")
+AS_AC_EXPAND(EXPANDED_LIBEXECDIR, "$libexecdir")
+AS_AC_EXPAND(EXPANDED_DATADIR, "$datadir")
+
+#### Directory to install the libexec binaries
+GOBJECT_INTROSPECTION_LIBDIR="$EXPANDED_LIBDIR"
+AC_SUBST(GOBJECT_INTROSPECTION_LIBDIR)
+AC_DEFINE_UNQUOTED(GOBJECT_INTROSPECTION_LIBDIR,"$GOBJECT_INTROSPECTION_LIBDIR", [Directory prefix for typelib installation])
+
PKG_CHECK_MODULES(GOBJECT, [gobject-2.0])
PKG_CHECK_MODULES(SCANNER, [gobject-2.0 gthread-2.0])