summaryrefslogtreecommitdiff
path: root/examples/library/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2019-11-09 15:26:27 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2019-11-09 16:17:54 +0100
commit3ed45723550a21d714ac34a82d20e4aa2d7f9958 (patch)
treed3440d2ca04ee6dd89374668480b2c82f9aaa178 /examples/library/configure.ac
parent2e9f0a4fc9c7f1ba4583eeb76859bbab8cd7c702 (diff)
downloadgobject-introspection-3ed45723550a21d714ac34a82d20e4aa2d7f9958.tar.gz
examples: Make self contained and add build system integration examples
The libgirepository example now is its own meson project. There now is a small library that is buildable with meson and autotools which creates a gir/typelib. Usefull for testing our build system integration and for small experiments. Fixes #287
Diffstat (limited to 'examples/library/configure.ac')
-rw-r--r--examples/library/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/examples/library/configure.ac b/examples/library/configure.ac
new file mode 100644
index 00000000..ee0453dd
--- /dev/null
+++ b/examples/library/configure.ac
@@ -0,0 +1,14 @@
+AC_PREREQ([2.63])
+AC_INIT([gi-sample-autotools], [0.0.1])
+
+AM_INIT_AUTOMAKE([1.11 no-define foreign])
+AM_SILENT_RULES([yes])
+
+LT_PREREQ([2.2])
+LT_INIT([disable-static])
+
+PKG_CHECK_MODULES(GISAMPLE, [gobject-2.0])
+GOBJECT_INTROSPECTION_CHECK([1.30.0])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT