summaryrefslogtreecommitdiff
path: root/gir/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@src.gnome.org>2008-11-26 15:47:35 +0000
committerColin Walters <walters@src.gnome.org>2008-11-26 15:47:35 +0000
commit517267dbfc166a44ac63a32a5fe76af21c04b2fe (patch)
tree7a1aa95ba9886442bbe3af87d693a18b8fa7c160 /gir/Makefile.am
parent34a95322d74db8e41f84fc0535f0a3786e7644a4 (diff)
downloadgobject-introspection-517267dbfc166a44ac63a32a5fe76af21c04b2fe.tar.gz
Add --libtool option which we expect Automake-using people to pass
svn path=/trunk/; revision=977
Diffstat (limited to 'gir/Makefile.am')
-rw-r--r--gir/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/gir/Makefile.am b/gir/Makefile.am
index c795091d..1f5bb138 100644
--- a/gir/Makefile.am
+++ b/gir/Makefile.am
@@ -19,6 +19,7 @@ GLib-2.0.gir: $(SCANNER_BIN) $(SCANNER_LIBS) Makefile glib-2.0.c
--noclosure \
--output $@ \
--strip-prefix=g \
+ --libtool="$(LIBTOOL)" \
--library=$(GLIB_LIBRARY) \
$(CPPFLAGS) \
-I$(GLIB_INCLUDEDIR) \
@@ -49,6 +50,7 @@ GObject-2.0.gir: GLib-2.0.gir $(SCANNER_BIN) $(SCANNER_LIBS) Makefile
--noclosure \
--output $@ \
--strip-prefix=g \
+ --libtool="$(LIBTOOL)" \
--include=GLib-2.0 \
--library=$(GOBJECT_LIBRARY) \
-I$(GOBJECT_INCLUDEDIR) \
@@ -75,6 +77,7 @@ GModule-2.0.gir: GLib-2.0.gir $(SCANNER_BIN) $(SCANNER_LIBS)
--noclosure \
--output $@ \
--strip-prefix=g \
+ --libtool="$(LIBTOOL)" \
--include=GLib-2.0 \
--library=$(GMODULE_LIBRARY) \
-I$(GMODULE_INCLUDEDIR) \
@@ -106,6 +109,7 @@ Gio-2.0.gir: GObject-2.0.gir $(SCANNER_BIN) $(SCANNER_LIBS) Makefile $(srcdir)/g
--noclosure \
--output $@ \
--strip-prefix=g \
+ --libtool="$(LIBTOOL)" \
--include=GObject-2.0 \
--library=$(GIO_LIBRARY) \
-I$(GIO_INCLUDEDIR) \
@@ -130,6 +134,7 @@ GIRepository-2.0.gir: GObject-2.0.gir $(SCANNER_BIN) $(SCANNER_LIBS) $(GIREPOSIT
--noclosure \
--output $@ \
--strip-prefix=g \
+ --libtool="$(LIBTOOL)" \
--include=GObject-2.0 \
--library=girepository \
-I$(srcdir)/girepository \