summaryrefslogtreecommitdiff
path: root/gir/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2010-06-16 20:34:18 -0400
committerColin Walters <walters@verbum.org>2010-06-17 13:05:59 -0400
commit5a4fa2bf5648d60d9fc0feb69080c9153b2abe02 (patch)
tree0a1f1f2c42740f4a812bfd39e32afb9d6a733c74 /gir/Makefile.am
parent929892fa9447d2abace21d02c86bb888fc6fd3df (diff)
downloadgobject-introspection-5a4fa2bf5648d60d9fc0feb69080c9153b2abe02.tar.gz
Support introspectable=no attribute, add warnings framework
This work allows us to move closer to replacing gtk-doc, among other things. We add a generic attribute "introspectable", and inside the typelib compiler if we see "introspectable=no", we don't put it in the typelib. This replaces the hackish pre-filter for varargs with a much more generic mechanism. The varargs is now handled in the scanner, and we emit introspectable=no for them. Add generic metadata to Node with references to file/line/column, which currently comes from symbols. Add scanner options --warn-all and --warn-error. https://bugzilla.gnome.org/show_bug.cgi?id=621570
Diffstat (limited to 'gir/Makefile.am')
-rw-r--r--gir/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gir/Makefile.am b/gir/Makefile.am
index 1d88accd..c07a239e 100644
--- a/gir/Makefile.am
+++ b/gir/Makefile.am
@@ -118,7 +118,7 @@ endif
Gio-2.0.gir: GObject-2.0.gir
Gio_2_0_gir_LIBS = $(GIO_LIBRARY)
-Gio_2_0_gir_SCANNERFLAGS = --noclosure --strip-prefix=g --c-include="gio/gio.h" --add-include-path=.
+Gio_2_0_gir_SCANNERFLAGS = --warn-all --strip-prefix=g --c-include="gio/gio.h" --add-include-path=.
Gio_2_0_gir_PACKAGES = gio-2.0 $(GIO_UNIX_PACKAGES)
Gio_2_0_gir_INCLUDES = GObject-2.0
Gio_2_0_gir_CFLAGS = \