summaryrefslogtreecommitdiff
path: root/gir/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@src.gnome.org>2008-08-28 21:19:22 +0000
committerColin Walters <walters@src.gnome.org>2008-08-28 21:19:22 +0000
commit33ce153ff89ca8511cbb557cc510e9ae08f7999e (patch)
treee9741ac0ceb20be978516f88b8cc4e3318198a65 /gir/Makefile.am
parent20311dea2f0423f9a7655e648da6a01c62422645 (diff)
downloadgobject-introspection-33ce153ff89ca8511cbb557cc510e9ae08f7999e.tar.gz
Expand aliases when generating typelibs
* gir/Makefile.am: Use --includedir * girepository/girparser.c: Recursively parse includes to pull in aliases and expand them. We need this to avoid putting unknown names in the typelibs. * tools/compiler.c: Add --includedir option. svn path=/trunk/; revision=512
Diffstat (limited to 'gir/Makefile.am')
-rw-r--r--gir/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gir/Makefile.am b/gir/Makefile.am
index 6b306bb5..acd4c9de 100644
--- a/gir/Makefile.am
+++ b/gir/Makefile.am
@@ -85,8 +85,8 @@ CLEANFILES = $(BUILT_SOURCES)
girdir=$(datadir)/gir
dist_gir_DATA = $(BUILT_SOURCES)
-%.typelib: %.gir $(top_builddir)/tools/g-ir-compiler$(EXEEXT)
- $(DEBUG) $(top_builddir)/tools/g-ir-compiler$(EXEEXT) $< -o $@
+%.typelib: %.gir $(top_builddir)/tools/g-ir-compiler$(EXEEXT) Makefile
+ $(DEBUG) $(top_builddir)/tools/g-ir-compiler$(EXEEXT) --includedir=. $(G_IR_COMPILER_OPTS) $< -o $@
typelibsdir = $(datadir)/girepository
typelibs_DATA = GLib.typelib GObject.typelib Gio.typelib