summaryrefslogtreecommitdiff
path: root/gir/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2009-02-19 17:52:22 -0500
committerColin Walters <walters@verbum.org>2009-02-20 09:10:46 -0500
commitff4628ced457a5460f854abb8cdf923cd67c4e6e (patch)
treea9ea00be6333511b7ea1232b039523731f1fe0b8 /gir/Makefile.am
parentc86b12154bda14294dddf58bf3026c487566e3af (diff)
downloadgobject-introspection-ff4628ced457a5460f854abb8cdf923cd67c4e6e.tar.gz
Bug 572423 - Support --c-include argument for specifying C headers
This option is for specifying inside the .gir what C header files should be included by C consumers (as opposed to parsed by the scanner).
Diffstat (limited to 'gir/Makefile.am')
-rw-r--r--gir/Makefile.am31
1 files changed, 18 insertions, 13 deletions
diff --git a/gir/Makefile.am b/gir/Makefile.am
index 9b1b7c64..f2dee100 100644
--- a/gir/Makefile.am
+++ b/gir/Makefile.am
@@ -31,7 +31,8 @@ GLib-2.0.gir: $(SCANNER_BIN) $(SCANNER_LIBS) Makefile glib-2.0.c
--noclosure \
--output $@ \
--strip-prefix=g \
- --libtool="$(LIBTOOL)" \
+ --libtool="$(LIBTOOL)" \
+ --c-include="glib.h" \
--library=$(GLIB_LIBRARY) \
--pkg glib-2.0 \
$(CPPFLAGS) \
@@ -63,13 +64,14 @@ GObject-2.0.gir: GLib-2.0.gir $(SCANNER_BIN) $(SCANNER_LIBS) Makefile
--noclosure \
--output $@ \
--strip-prefix=g \
- --libtool="$(LIBTOOL)" \
- --include=GLib-2.0 \
+ --libtool="$(LIBTOOL)" \
+ --c-include="glib-object.h" \
+ --include=GLib-2.0 \
--library=$(GOBJECT_LIBRARY) \
-I$(GOBJECT_INCLUDEDIR) \
-I$(GOBJECT_LIBDIR)/glib-2.0/include \
-DGOBJECT_COMPILATION \
- --pkg gobject-2.0 \
+ --pkg gobject-2.0 \
$(GLIB_INCLUDEDIR)/gobject/*.h
$(SCANNER) $(SCANNER_ARGS) \
--xpath-assertions=$(srcdir)/GObject-2.0.xpath GObject-2.0.gir
@@ -92,12 +94,13 @@ GModule-2.0.gir: GLib-2.0.gir $(SCANNER_BIN) $(SCANNER_LIBS)
--noclosure \
--output $@ \
--strip-prefix=g \
- --libtool="$(LIBTOOL)" \
- --include=GLib-2.0 \
+ --libtool="$(LIBTOOL)" \
+ --c-include="gmodule.h" \
+ --include=GLib-2.0 \
--library=$(GMODULE_LIBRARY) \
-I$(GMODULE_INCLUDEDIR) \
-I$(GMODULE_LIBDIR)/glib-2.0/include \
- --pkg gmodule-2.0 \
+ --pkg gmodule-2.0 \
$(GLIB_INCLUDEDIR)/gmodule.h
BUILT_GIRSOURCES += GModule-2.0.gir
@@ -124,8 +127,9 @@ Gio-2.0.gir: GObject-2.0.gir $(SCANNER_BIN) $(SCANNER_LIBS) Makefile $(srcdir)/g
--noclosure \
--output $@ \
--strip-prefix=g \
- --libtool="$(LIBTOOL)" \
- --include=GObject-2.0 \
+ --libtool="$(LIBTOOL)" \
+ --c-include="gio/gio.h" \
+ --include=GObject-2.0 \
--library=$(GIO_LIBRARY) \
-I$(GIO_INCLUDEDIR) \
-I$(GIO_LIBDIR)/glib-2.0/include \
@@ -148,12 +152,13 @@ GIRepository-2.0.gir: GObject-2.0.gir $(SCANNER_BIN) $(SCANNER_LIBS) $(GIREPOSIT
--noclosure \
--output $@ \
--strip-prefix=g \
- --libtool="$(LIBTOOL)" \
- --include=GObject-2.0 \
+ --libtool="$(LIBTOOL)" \
+ --c-include="girepository.h" \
+ --include=GObject-2.0 \
--library=girepository-1.0 \
-I$(srcdir)/girepository \
- --pkg glib-2.0 \
- --pkg gobject-2.0 \
+ --pkg glib-2.0 \
+ --pkg gobject-2.0 \
$(GIREPOSITORY_FILES)
BUILT_GIRSOURCES += GIRepository-2.0.gir