summaryrefslogtreecommitdiff
path: root/gir/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-08-05 14:18:12 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-08-05 14:18:12 +0100
commit3e1a6a010742fa454ffae0a79565a1ae1890ae35 (patch)
tree9741a79bb71d85d36e138fc8bbafc04f98d97cf4 /gir/meson.build
parentc691d9f03b93baddcd1f4e979a97e8d72a27d893 (diff)
downloadgobject-introspection-3e1a6a010742fa454ffae0a79565a1ae1890ae35.tar.gz
Port the girepository API reference to gi-docgengidocgen
We use the introspection data as the source for our documentation. The gtk-doc project is unmaintained, and parsing our code twice isn't the best use of our build time. This might be the chance for getting a better girepository documentation and introspection data, as well.
Diffstat (limited to 'gir/meson.build')
-rw-r--r--gir/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/gir/meson.build b/gir/meson.build
index 5d646335..2c0c9a94 100644
--- a/gir/meson.build
+++ b/gir/meson.build
@@ -476,7 +476,7 @@ if dep_type != 'pkgconfig'
girepository_command += glib_libpaths
endif
-gir_files += custom_target('gir-girepository',
+girepository_gir = custom_target('gir-girepository',
input: girepo_gir_sources,
output: 'GIRepository-2.0.gir',
depends: [gobject_gir, gir_giscanner_pymod, girepo_lib],
@@ -494,6 +494,8 @@ gir_files += custom_target('gir-girepository',
]
)
+gir_files += girepository_gir
+
typelibs = []
if get_option('gi_cross_binary_wrapper') != ''
gircompiler_command = [get_option('gi_cross_binary_wrapper'), gircompiler.full_path(), ]