summaryrefslogtreecommitdiff
path: root/gir/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2022-07-13 14:49:29 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2022-07-13 14:49:29 +0100
commit3b5db10205023bfa43a9675a6ade826653a1c41c (patch)
treed7a2e95fecbdc96c73fb0218bfa32a54337a7c40 /gir/meson.build
parentb20205170f5656b3d0aa3cbc3cee8a3c0f54233d (diff)
downloadgobject-introspection-3b5db10205023bfa43a9675a6ade826653a1c41c.tar.gz
build: Add run_command() argument
The `check` argument to `run_command()` is now mandatory.
Diffstat (limited to 'gir/meson.build')
-rw-r--r--gir/meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/gir/meson.build b/gir/meson.build
index 2c658c03..dc39b475 100644
--- a/gir/meson.build
+++ b/gir/meson.build
@@ -113,7 +113,7 @@ if dep_type == 'pkgconfig'
glib_files += join_paths(glib_incdir, 'glib-unix.h')
endif
# Parse glob to get installed header list
- ret = run_command(python, '-c', globber.format(join_paths(glib_incdir, 'glib', '*.h')))
+ ret = run_command(python, '-c', globber.format(join_paths(glib_incdir, 'glib', '*.h')), check: true)
if ret.returncode() != 0
error('Failed to get glib header list')
endif
@@ -121,7 +121,7 @@ if dep_type == 'pkgconfig'
# Get a list of all source files
glib_srcdir = get_option('glib_src_dir')
if glib_srcdir != ''
- ret = run_command(python, '-c', globber.format(join_paths(glib_srcdir, 'glib', '*.c')))
+ ret = run_command(python, '-c', globber.format(join_paths(glib_srcdir, 'glib', '*.c')), check: true)
if ret.returncode() != 0
error('Failed to get glib source list')
endif
@@ -263,13 +263,13 @@ gobject_command = scanner_command + [
if dep_type == 'pkgconfig'
gobject_command += ['--external-library', '--pkg=gobject-2.0']
# Get the installed header list
- ret = run_command(python, '-c', globber.format(join_paths(glib_incdir, 'gobject', '*.h')))
+ ret = run_command(python, '-c', globber.format(join_paths(glib_incdir, 'gobject', '*.h')), check: true)
if ret.returncode() != 0
error('Failed to get gobject header list')
endif
gobject_headers = ret.stdout().strip().split('\n')
if glib_srcdir != ''
- ret = run_command(python, '-c', globber.format(join_paths(glib_srcdir, 'gobject', '*.c')))
+ ret = run_command(python, '-c', globber.format(join_paths(glib_srcdir, 'gobject', '*.c')), check: true)
if ret.returncode() != 0
error('Failed to get gobject source list')
endif
@@ -379,7 +379,7 @@ gio_command = scanner_command + [
if dep_type == 'pkgconfig'
gio_command += ['--external-library', '--pkg=gio-2.0']
# Get the installed header list
- ret = run_command(python, '-c', globber.format(join_paths(glib_incdir, 'gio', '*.h')))
+ ret = run_command(python, '-c', globber.format(join_paths(glib_incdir, 'gio', '*.h')), check: true)
if ret.returncode() != 0
error('Failed to get gio header list')
endif
@@ -388,7 +388,7 @@ if dep_type == 'pkgconfig'
# probably fine since it matches what Autotools does. We are more exact in
# the subproject case.
if glib_srcdir != ''
- ret = run_command(python, '-c', globber.format(join_paths(glib_srcdir, 'gio', '*.c')))
+ ret = run_command(python, '-c', globber.format(join_paths(glib_srcdir, 'gio', '*.c')), check: true)
if ret.returncode() != 0
error('Failed to get gio source list')
endif
@@ -420,7 +420,7 @@ if giounix_dep.found()
gio_command += ['--pkg=gio-unix-2.0']
giounix_includedir = get_option('gi_cross_pkgconfig_sysroot_path') + join_paths(giounix_dep.get_variable(pkgconfig: 'includedir'), 'gio-unix-2.0')
# Get the installed gio-unix header list
- ret = run_command(python, '-c', globber.format(join_paths(giounix_includedir, 'gio', '*.h')))
+ ret = run_command(python, '-c', globber.format(join_paths(giounix_includedir, 'gio', '*.h')), check: true)
if ret.returncode() != 0
error('Failed to get gio-unix header list')
endif