summaryrefslogtreecommitdiff
path: root/girepository/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@gnome.org>2008-08-09 12:46:48 +0000
committerJohan Dahlin <johan@src.gnome.org>2008-08-09 12:46:48 +0000
commitc37a96568cec88cb82ba3eadfaf513578eca7c76 (patch)
tree2185ece8e97167ec65e37ec866f7486e5b5eb88f /girepository/Makefile.am
parentb9c41e1af4e481c370806996cfa1e7ca61226a60 (diff)
downloadgobject-introspection-c37a96568cec88cb82ba3eadfaf513578eca7c76.tar.gz
Move shared *.[ch] files to girepository from tools
2008-08-09 Johan Dahlin <johan@gnome.org> * girepository/Makefile.am: * tools/Makefile.am: * tools/girmodule.c: * tools/girmodule.h: * tools/girnode.c: * tools/girnode.h: * tools/girparser.c: * tools/girparser.h: * tools/girwriter.c: * tools/girwriter.h: Move shared *.[ch] files to girepository from tools svn path=/trunk/; revision=337
Diffstat (limited to 'girepository/Makefile.am')
-rw-r--r--girepository/Makefile.am19
1 files changed, 14 insertions, 5 deletions
diff --git a/girepository/Makefile.am b/girepository/Makefile.am
index 79033637..36e7baf9 100644
--- a/girepository/Makefile.am
+++ b/girepository/Makefile.am
@@ -1,10 +1,14 @@
-## Process this file with automake to produce Makefile.in
-
include $(top_srcdir)/gcov.mak
+GCOVSOURCES = $(libgirepository_la_SOURCES)
+
INCLUDES = -DGIREPO_DEFAULT_SEARCH_PATH="\"$(libdir)\""
+girepodir = $(includedir)/gobject-introspection-1.0/
+girepo_HEADERS = girepository.h
+
lib_LTLIBRARIES = libgirepository.la
+noinst_LTLIBRARIES = libgirepository-parser.la
libgirepository_la_SOURCES = \
girepository.c \
@@ -15,7 +19,12 @@ libgirepository_la_SOURCES = \
libgirepository_la_CPPFLAGS = $(GIREPO_CFLAGS)
libgirepository_la_LIBADD = $(GIREPO_LIBS)
-girepodir = $(includedir)/gobject-introspection-1.0/
-girepo_HEADERS = girepository.h
+libgirepository_parser_la_SOURCES = \
+ girmodule.c \
+ girmodule.h \
+ girnode.c \
+ girnode.h \
+ girparser.c \
+ girparser.h
+libgirepository_parser_la_CFLAGS = $(GIREPO_CFLAGS)
-GCOVSOURCES = $(libgirepository_la_SOURCES)