summaryrefslogtreecommitdiff
path: root/girepository/cmph/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2017-11-23 13:45:37 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-03-10 19:05:19 +0530
commit5d15d65e26504b2188ffb42b2bf8a32e22a5add8 (patch)
treeea9f2d4335a23cb188fbb371c2b7c65bc1eefc61 /girepository/cmph/meson.build
parentc2b2a76b00ec0a994426509ccd6b9dedd077f19b (diff)
downloadgobject-introspection-5d15d65e26504b2188ffb42b2bf8a32e22a5add8.tar.gz
meson: Use glib_dep and configinc for girepository
glib_dep is what is actually needed to #include <glib.h>, not gobject_dep. It works incidentally with system gobject/glib but not when built via subprojects.
Diffstat (limited to 'girepository/cmph/meson.build')
-rw-r--r--girepository/cmph/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/girepository/cmph/meson.build b/girepository/cmph/meson.build
index 0c0e0af5..368afc7b 100644
--- a/girepository/cmph/meson.build
+++ b/girepository/cmph/meson.build
@@ -25,7 +25,7 @@ cmph_sources = [
]
cmph_deps = [
- gobject_dep,
+ glib_dep,
cc.find_library('m', required: false),
]
@@ -43,7 +43,7 @@ cmph_dep = declare_dependency(
cmph_test = executable('cmph-bdz-test', '../cmph-bdz-test.c',
dependencies: [
cmph_dep,
- gobject_dep,
+ glib_dep,
]
)