summaryrefslogtreecommitdiff
path: root/giscanner/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2010-07-27 06:16:37 -0400
committerColin Walters <walters@verbum.org>2010-08-31 16:05:56 -0400
commit36aa515f1036978ced8d4ffb808260844f7229e0 (patch)
tree93e06fb105a513a394365232bb632256f109dada /giscanner/Makefile.am
parent552c1f1525e37a30376790151c1ba437776682c5 (diff)
downloadgobject-introspection-36aa515f1036978ced8d4ffb808260844f7229e0.tar.gz
Major rewrite
One of the first big changes in this rewrite is changing the Type object to have separate target_fundamental and target_giname properties, rather than just being strings. Previously in the scanner, it was awful because we used heuristics around strings. The ast.py is refactored so that not everything is a Node - that was a rather useless abstraction. Now, only things which can have a GIName are Node. E.g. Type and Field are no longer Node. More things were merged from glibast.py into ast.py, since it isn't a very useful split. transformer.py gains more intelligence and will e.g. turn GLib.List into a List() object earlier. The namespace processing is a lot cleaner now; since we parse the included .girs, we know the C prefix for each namespace, and have functions to parse both C type names (GtkFooBar) and symbols gtk_foo_bar into their symbols cleanly. Type resolution is much, much saner because we know Type(target_giname=Gtk.Foo) maps to the namespace Gtk. glibtransformer.py now just handles the XML processing from the dump, and a few miscellaneous things. The major heavy lifting now lives in primarytransformer.py, which is a combination of most of annotationparser.py and half of glibtransformer.py. annotationparser.py now literally just parses annotations; it's no longer in the business of e.g. guessing transfer too. finaltransformer.py is a new file which does post-analysis for "introspectability" mainly. girparser.c is fixed for some introspectable=0 processing.
Diffstat (limited to 'giscanner/Makefile.am')
-rw-r--r--giscanner/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/giscanner/Makefile.am b/giscanner/Makefile.am
index 642bcbc5..708fdf8a 100644
--- a/giscanner/Makefile.am
+++ b/giscanner/Makefile.am
@@ -36,18 +36,22 @@ pkgpyexec_PYTHON = \
annotationparser.py \
ast.py \
cachestore.py \
+ codegen.py \
config.py \
dumper.py \
+ introspectablepass.py \
girparser.py \
girwriter.py \
glibast.py \
- glibtransformer.py \
+ gdumpparser.py \
libtoolimporter.py \
minixpath.py \
odict.py \
+ primarytransformer.py \
shlibs.py \
scannermain.py \
sourcescanner.py \
+ testcodegen.py \
transformer.py \
utils.py \
xmlwriter.py