summaryrefslogtreecommitdiff
path: root/giscanner/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2010-11-04 13:12:12 -0400
committerColin Walters <walters@verbum.org>2010-11-09 13:56:43 -0500
commitf43f3a722323448dfce514a2b435390fd837ddee (patch)
treeebc3b6ebf329848a92d467b050ca8abf5e2e2daf /giscanner/Makefile.am
parent2681a9dcb1182d8b0fc34fbb341d77a0a13c65f2 (diff)
downloadgobject-introspection-f43f3a722323448dfce514a2b435390fd837ddee.tar.gz
Switch to nonrecursive make for core (i.e. not tests/)
This is cleaner and faster, and prepares us better for an incoming import of CMPH.
Diffstat (limited to 'giscanner/Makefile.am')
-rw-r--r--giscanner/Makefile.am87
1 files changed, 0 insertions, 87 deletions
diff --git a/giscanner/Makefile.am b/giscanner/Makefile.am
deleted file mode 100644
index 2779b70c..00000000
--- a/giscanner/Makefile.am
+++ /dev/null
@@ -1,87 +0,0 @@
-## Process this file with automake to produce Makefile.in
-
-INCLUDES = -I$(top_srcdir)/girepository
-BUILT_SOURCES = \
- scannerparser.c \
- scannerparser.h \
- scannerlexer.c \
- scannerlexer.h
-
-CLEANFILES = \
- scannerparser.c \
- scannerparser.h \
- scannerlexer.c \
- scannerlexer.h
-AM_YFLAGS = -d -t
-
-# Why do I have to do this automake?
-scannerlexer.h: scannerlexer.c
-
-noinst_LTLIBRARIES = libgiscanner.la
-
-libgiscanner_la_SOURCES = \
- sourcescanner.c \
- sourcescanner.h \
- scannerlexer.l \
- scannerparser.y \
- grealpath.h
-libgiscanner_la_LIBADD = $(GOBJECT_LIBS)
-libgiscanner_la_CFLAGS = $(GOBJECT_CFLAGS)
-
-# Python module
-pkgpyexecdir = $(pkglibdir)/giscanner
-pkgpyexec_LTLIBRARIES = _giscanner.la
-pkgpyexec_PYTHON = \
- __init__.py \
- annotationmain.py \
- annotationparser.py \
- ast.py \
- cachestore.py \
- codegen.py \
- config.py \
- dumper.py \
- introspectablepass.py \
- girparser.py \
- girwriter.py \
- gdumpparser.py \
- libtoolimporter.py \
- odict.py \
- maintransformer.py \
- message.py \
- shlibs.py \
- scannermain.py \
- sourcescanner.py \
- testcodegen.py \
- transformer.py \
- utils.py \
- xmlwriter.py
-
-_giscanner_la_CFLAGS = \
- $(PYTHON_INCLUDES) \
- $(GOBJECT_CFLAGS) \
- -I$(top_srcdir)/giscanner
-_giscanner_la_LIBADD = libgiscanner.la $(GOBJECT_LIBS)
-
-_giscanner_la_LDFLAGS = \
- -module -avoid-version -export-symbols-regex init_giscanner
-
-if OS_WIN32
-# Yuck. Probably there is a way to get this from Python, but I don't
-# know how. Use -Wl to avoid libtool crack.
-_giscanner_la_LDFLAGS += -Wl,$(pyexecdir)/../../libs/libpython25.a -no-undefined
-endif
-
-_giscanner_la_SOURCES = giscannermodule.c
-
-if OS_WIN32
-BUILT_SOURCES += _giscanner.pyd
-CLEANFILES += _giscanner.pyd
-
-_giscanner.pyd: _giscanner.la
- cp .libs/_giscanner.dll $@
-
-install-exec-hook:
- mv $(pkgpyexecdir)/_giscanner.dll $(pkgpyexecdir)/_giscanner.pyd
- rm $(pkgpyexecdir)/_giscanner.dll.a
- rm $(pkgpyexecdir)/_giscanner.la
-endif