summaryrefslogtreecommitdiff
path: root/giscanner/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-07-11 18:49:27 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-11 20:44:52 +0200
commit2dbf8f4ea4992ca33c272786f860d7fc291ba89b (patch)
treefca28df47c9d2e3afc991c19de68fe80db477e18 /giscanner/meson.build
parent4542321c383304807228f204de600aa64944c87e (diff)
downloadgobject-introspection-2dbf8f4ea4992ca33c272786f860d7fc291ba89b.tar.gz
meson: Add a "python" option to make the python to build against configurable
This allows us to build with Python 2 and run tests with it. This requires the new "python" meson module which was added in 0.46.0 so bump the required meson version (glib needs a newer one anyway). Also fixes a small test error under Python 2.
Diffstat (limited to 'giscanner/meson.build')
-rw-r--r--giscanner/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/giscanner/meson.build b/giscanner/meson.build
index 5a1e44c9..b4ec3796 100644
--- a/giscanner/meson.build
+++ b/giscanner/meson.build
@@ -79,12 +79,12 @@ giscanner_lib = static_library('giscanner',
dependencies: [glib_dep, gobject_dep, gio_dep, gmodule_dep],
)
-giscanner_pymod = py3.extension_module('_giscanner', 'giscannermodule.c',
+giscanner_pymod = python.extension_module('_giscanner', ['giscannermodule.c'],
link_with: giscanner_lib,
c_args: [gi_hidden_visibility_cflags],
include_directories : configinc,
dependencies: [glib_dep, gobject_dep, gio_dep, gmodule_dep,
- dependency('python3')],
+ python.dependency()],
install: true,
install_dir: giscannerdir,
)