summaryrefslogtreecommitdiff
path: root/giscanner/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2017-11-24 02:24:17 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-03-10 19:05:19 +0530
commit3a7d3eee01dd5213547290c2b01db0810d4f50cc (patch)
treeb59d4bfcfe611ccea21bac93692859a8b7f36a06 /giscanner/meson.build
parentaae69e73eb3ce04f643e9697e46823e41cdb4eea (diff)
downloadgobject-introspection-3a7d3eee01dd5213547290c2b01db0810d4f50cc.tar.gz
giscanner: Remove custom collections implementation
We already require python 2.7, and it has OrderedDict and Counter. Besides cleaning up unmaintained code, this change found and fixed a Python 3 bug where we were iterating over a dict while changing it.
Diffstat (limited to 'giscanner/meson.build')
-rw-r--r--giscanner/meson.build5
1 files changed, 0 insertions, 5 deletions
diff --git a/giscanner/meson.build b/giscanner/meson.build
index e9a9c3cd..acf14863 100644
--- a/giscanner/meson.build
+++ b/giscanner/meson.build
@@ -29,11 +29,6 @@ install_data([
'xmlwriter.py',
], install_dir: giscannerdir)
-install_data([
- 'collections/__init__.py',
- 'collections/counter.py',
- 'collections/ordereddict.py',
-], install_dir: join_paths(giscannerdir, 'collections'))
install_subdir('doctemplates', install_dir: giscannerdir)