summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2017-11-23 13:48:13 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-03-10 19:05:19 +0530
commitaae69e73eb3ce04f643e9697e46823e41cdb4eea (patch)
tree681c65e1282422b9a2d79c228da5100015336fa3 /meson.build
parent8e8523ab3a9ddf4110ffb66ca16213ab29693efd (diff)
downloadgobject-introspection-aae69e73eb3ce04f643e9697e46823e41cdb4eea.tar.gz
meson: Rewrite glib gir generation
The previous build files had a bunch of problems: 1. It assumed that glib would only be sourced via pkg-config 2. It was using the system gobject-introspection-1.0.pc file while building GIRepository-1.0.gir 3. It wasn't ignoring the *-autocleanup.h headers properly Now you can build glib as a subproject and generate girs against the in-tree sources. This also yields more accurate girs because they document platform-specific features that are actually enabled in the glib build we are linking against.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2573776b..7ae703fd 100644
--- a/meson.build
+++ b/meson.build
@@ -13,6 +13,7 @@ gi_versions = meson.project_version().split('.')
configinc = include_directories('.')
py3 = import('python3')
+python3 = py3.find_python()
cc = meson.get_compiler('c')
config = configuration_data()