summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-13 17:33:43 +0100
committerAlexander Kanavin <alex.kanavin@gmail.com>2019-12-13 17:40:36 +0100
commit284b4c828a84a776233fc21438640d974c52394d (patch)
treef16138daeaaba7ad028a19b99f5d94804c6006d1 /meson.build
parentf2dca4e6a796560944b2ef8c158f6cc247f2ae5d (diff)
downloadgobject-introspection-284b4c828a84a776233fc21438640d974c52394d.tar.gz
meson: address review comments
See here: https://gitlab.gnome.org/GNOME/gobject-introspection/merge_requests/64 Particularly, options are renamed to make it more readable and clear. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 03ab4176..031af630 100644
--- a/meson.build
+++ b/meson.build
@@ -196,10 +196,17 @@ endif
subdir('girepository')
subdir('tools')
subdir('giscanner')
-if get_option('enable-introspection-data') == true
+
+# Not building gir data might be useful in cross-compilation
+# scenarios where running target binaries through software emulation
+# is not possible (due to the SW emulation missing support for target HW).
+if get_option('build_introspection_data') == true
subdir('gir')
endif
subdir('docs')
+
+# The tests will also run, which is not possible if they
+# were built for a different architecture.
if not meson.is_cross_build()
subdir('tests')
endif