summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2023-01-07 23:44:44 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2023-01-08 00:38:33 +0000
commit9fa744744572ecc749b2ff7dbbf271b91440cd7e (patch)
treecbaa74e6e011b4f52cf4559a097cca200660c007 /meson.build
parenta0192ba32aa25c24a71d11d7da974c47b6e35e4d (diff)
downloadgobject-introspection-9fa744744572ecc749b2ff7dbbf271b91440cd7e.tar.gz
build: Drop wrap files for GLib dependencies
We don't need wrap files for things we get from GLib or from the system.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 240a2387..1452309c 100644
--- a/meson.build
+++ b/meson.build
@@ -147,8 +147,9 @@ else
giowin_dep = dependency('gio-windows-2.0', version : glib_version,
fallback: ['glib', 'libgiowin32_dep'])
endif
-libffi_dep = dependency('libffi',
- fallback : ['libffi', 'ffi_dep'])
+
+# We either get libffi from the system, or from GLib's own subproject
+libffi_dep = dependency('libffi')
if not (host_system == 'darwin' and host_arch == 'aarch64' or
host_system == 'linux' and libffi_dep.version().version_compare('>= 3.4'))