summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-11-15 15:10:05 +0100
committerAlexander Kanavin <alex.kanavin@gmail.com>2019-12-13 17:07:51 +0100
commit1707d9b215aa85fd3aca56555ad14f02b3bd0afe (patch)
tree24c28faa9e7d928e950e04113328650cb784e39f /meson.build
parent48f41930a773bdd48b9664b2fc5b1e45d6bc5688 (diff)
downloadgobject-introspection-1707d9b215aa85fd3aca56555ad14f02b3bd0afe.tar.gz
meson_options.txt: add host-gi, gi-cross-wrapper, gi-ldd-wrapper, introspection-data and pkgconfig-sysroot-path options
With the first option, gobject-introspection tools (g-ir-doc-tool and g-ir-scanner) that are already installed in the host system will be used for building the source tree. With the second option, g-ir-scanner will be instructed to use an executable wrapper to run binaries it's producing, and g-ir-compiler will be run through the same wrapper (host system's g-ir-compiler cannot be used because it's producing architecture-specific output). With the third option, giscanner will be instructed to use a special ldd command instead of system's ldd (which does not work when the binary to inspect is compiled for a different architecture). With the fourth option, it is possible to disable building of introspection data (.gir and .typelib files), which may be difficult or impossible in cross-compilation environments, because of lack of emulation (or native hardware) for the target architecture on which the target binaries can be run. With the fifth option, paths returned by pkg-config are prefixed with the sysroot path (which is the destination path for cross-compiled items on the system where cross-compilation happens). These options are useful when cross-compiling for a different target architecture. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index df18e467..f8f52d14 100644
--- a/meson.build
+++ b/meson.build
@@ -196,7 +196,9 @@ endif
subdir('girepository')
subdir('tools')
subdir('giscanner')
-subdir('gir')
+if get_option('enable-introspection-data') == true
+ subdir('gir')
+endif
subdir('docs')
subdir('tests')