summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2019-08-15 09:41:30 -0400
committerThibault Saunier <saunierthibault@gmail.com>2019-08-15 13:58:07 +0000
commitba744068f2075dad4d5d3562c79034f23a6bb90a (patch)
tree678e417910d3c48db1af0c157cc6b8c4c849e94b /meson.build
parent722d59c14cd0a82a0373fb305d0157f5281c076e (diff)
downloadgobject-introspection-ba744068f2075dad4d5d3562c79034f23a6bb90a.tar.gz
Make meson.override_find_program working on more complex use cases
Add some missing `meson.override_find_program` And make sure that the `.gir` we build are found when used uninstalled as a concequence of `meson.override_find_program`.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7d71c8e5..bd6eaa48 100644
--- a/meson.build
+++ b/meson.build
@@ -90,6 +90,7 @@ endif
girdir = join_paths(gir_dir_prefix, 'gir-1.0')
config.set_quoted('GIR_DIR', girdir)
config.set_quoted('GOBJECT_INTROSPECTION_LIBDIR', join_paths(get_option('prefix'), get_option('libdir')))
+config.set_quoted('UNINSTALLED_GIR_DIR', join_paths(meson.current_build_dir(), 'gir'))
foreach type : ['char', 'short', 'int', 'long']
size = cc.sizeof(type)