summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2019-04-30 16:07:39 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2019-04-30 16:07:39 +0800
commit26f542484ebe88ef231ff36e8853f806dd7ecfd3 (patch)
tree36e432b7c16af7aefbac98cbb6a52dcf51091979 /meson.build
parentd2faab30b91ae54fb82bd4b964b9ef7df9e8dd60 (diff)
downloadgobject-introspection-26f542484ebe88ef231ff36e8853f806dd7ecfd3.tar.gz
build: Force-include msvc_recommended_pragmas.h on Visual Studio
By doing so, we essentially cover the various compiler flags that we want to use for non-Visual Studio builds to check for warnings that might cause real concern. This also skips the checks for the various GCC-isque CFlag checks that are scattered in the various build files on Visual Studio builds, since they are essentially meaningless on Visual Studio builds.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d5709521..941d63ec 100644
--- a/meson.build
+++ b/meson.build
@@ -63,6 +63,10 @@ if cc.get_id() != 'msvc'
project_c_args += [
'-fno-strict-aliasing',
]
+else
+ project_c_args += [
+ '-FImsvc_recommended_pragmas.h',
+ ]
endif
project_c_args = cc.get_supported_arguments(project_c_args)