summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2020-05-19 19:39:34 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2020-05-19 19:39:34 +0200
commit89c81712570e98e5ee411275c0fa467a6b61e977 (patch)
treeadb80e3783fc26979e0d1abf43c2de0f16f1bb85 /meson.build
parent5b9cf70d4ea36fd95449855cbbad592dabc653cc (diff)
downloadgobject-introspection-89c81712570e98e5ee411275c0fa467a6b61e977.tar.gz
meson: also build gi-dump-types on Windows
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6f3ba8c8..506757d2 100644
--- a/meson.build
+++ b/meson.build
@@ -144,12 +144,15 @@ gmodule_dep = dependency('gmodule-2.0', version : glib_version,
if host_system != 'windows'
giounix_dep = dependency('gio-unix-2.0', version : glib_version,
fallback: ['glib', 'libgiounix_dep'])
+ giowin_dep = dependency('', required : false)
else
# Don't even try to look for gio-unix-2.0 on Windows because Meson will
# fruitlessly try to find it in the glib subproject even when we don't want
# it to look in the subproject at all. Just use a not-found dependency.
giounix_dep = dependency('', required : false)
# XXX: Autotools doesn't build girs for gio-win32-2.0, but maybe we should?
+ giowin_dep = dependency('gio-windows-2.0', version : glib_version,
+ fallback: ['glib', 'libgiowin32_dep'])
endif
libffi_dep = dependency('libffi',
fallback : ['libffi', 'ffi_dep'])