summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2020-11-12 18:23:11 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2020-11-12 18:23:11 +0100
commite23dc019be61c6f8a573d3880a8423690bb0e413 (patch)
treeb4fd4895f119cdc73f5d8805f56fac9b022eceff /meson.build
parentaa0bbaa548bd31933d3cbf5257d9487574e072d2 (diff)
downloadgobject-introspection-e23dc019be61c6f8a573d3880a8423690bb0e413.tar.gz
Require Python 3.6
3.5 is EOL now and we'd like to use newer typing features
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 546ab885..e81623e5 100644
--- a/meson.build
+++ b/meson.build
@@ -18,7 +18,7 @@ pymod = import('python')
python = pymod.find_installation(get_option('python'))
python_version = python.language_version()
-python_version_req = '>=3.5'
+python_version_req = '>=3.6'
if not python_version.version_compare(python_version_req)
error('Requires Python @0@, @1@ found.'.format(python_version_req, python_version))
endif