summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2019-07-26 18:46:15 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2019-07-26 18:18:23 +0000
commite8ba84091eadbe1b0edabf9ec276f00651729aa7 (patch)
treeca5f03ed2b615fcbcde9d21e012e311e96e672ef /meson.build
parent91bbef9e27dd1d7bcd4f4d9852c0edd0d3af82e9 (diff)
downloadgobject-introspection-e8ba84091eadbe1b0edabf9ec276f00651729aa7.tar.gz
meson: don't pass "install" to configure_file() unless really needed
In our case it was never needed because it defaults to true if install_dir is set, which it always is for all calls. This avoids a warning when running with newer meson where it complains that install is only available with 0.50+. Fixes #298
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 0 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0a123e14..83dac0fd 100644
--- a/meson.build
+++ b/meson.build
@@ -207,7 +207,6 @@ configure_file(
input: 'gobject-introspection-no-export-1.0.pc.in',
output: 'gobject-introspection-no-export-1.0.pc',
configuration: pkgconfig_conf,
- install: true,
install_dir: join_paths(get_option('libdir'), 'pkgconfig'),
)
@@ -215,6 +214,5 @@ configure_file(
input: 'gobject-introspection-1.0.pc.in',
output: 'gobject-introspection-1.0.pc',
configuration: pkgconfig_conf,
- install: true,
install_dir: join_paths(get_option('libdir'), 'pkgconfig'),
)