summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2021-02-23 13:11:22 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2021-05-23 12:56:21 -0400
commitf9c1b6f65bec623d593835c400d2d55d981715c8 (patch)
tree2fbcc56bc165ba6d15268eb2e22588027e2a26d0 /meson.build
parent00bce5569b5e7fd0f6e373857a89996e07bf0725 (diff)
downloadgobject-introspection-f9c1b6f65bec623d593835c400d2d55d981715c8.tar.gz
Make test suite work with cross-related options
Because of skepticism I received in #224, I made this PR which keeps the testsuite and CI improvements but doesn't add any new build options. I hope this would be less controversial: - no new knobs - tests for those using existing build options - CI tests `build_introspection_data = false`
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 9638a5ab..4460e40c 100644
--- a/meson.build
+++ b/meson.build
@@ -218,14 +218,19 @@ subdir('giscanner')
# scenarios where running target binaries through software emulation
# is not possible (due to the SW emulation missing support for target HW).
if get_option('build_introspection_data') == true
- subdir('gir')
+ subdir('gir')
+else
+ # for tests
+ typelibs = disabler()
+ gobject_gir = disabler()
+ gio_gir = disabler()
endif
subdir('docs')
# The tests will also run, which is not possible if they
# were built for a different architecture.
if not meson.is_cross_build()
- subdir('tests')
+ subdir('tests')
endif
install_data('Makefile.introspection', install_dir: join_paths(get_option('datadir'), 'gobject-introspection-1.0'))