summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2020-05-06 14:24:34 -0400
committerXavier Claessens <xavier.claessens@collabora.com>2020-05-06 14:24:34 -0400
commitf8e080d03bb490e3539a2a7e0c4a5e7a20fcd863 (patch)
treef1eec668d91f881e047869352350db7b9c6ea5f6 /meson.build
parent769f886bfa3c7b21815def592eec7279bb123f23 (diff)
downloadgobject-introspection-f8e080d03bb490e3539a2a7e0c4a5e7a20fcd863.tar.gz
Meson: Fix build as subproject
meson.build_root() is the root of the main project, better use meson.current_build_dir() instead.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c730b2c6..6f3ba8c8 100644
--- a/meson.build
+++ b/meson.build
@@ -9,6 +9,8 @@ project('gobject-introspection', 'c',
host_system = host_machine.system()
gi_versions = meson.project_version().split('.')
+build_root = meson.current_build_dir()
+source_root = meson.current_source_dir()
configinc = include_directories('.')