summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-11-04 13:23:17 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-11-05 16:52:35 +0000
commit1ff23a5d290de418655e7e67e522eacbda317115 (patch)
tree2655940d5153486c485402db2c53d51ad67ad364 /meson.build
parent5156a1d5dca41f9e5197809e42569d527449ecbb (diff)
downloadgobject-introspection-1ff23a5d290de418655e7e67e522eacbda317115.tar.gz
Drop Python 2 support, require Python 3.4+
glib did the same thing this cycle, see https://gitlab.gnome.org/GNOME/glib/merge_requests/196 for details
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4022e319..cf99b605 100644
--- a/meson.build
+++ b/meson.build
@@ -15,6 +15,12 @@ configinc = include_directories('.')
pymod = import('python')
python = pymod.find_installation(get_option('python'))
+python_version = python.language_version()
+python_version_req = '>=3.4'
+if not python_version.version_compare(python_version_req)
+ error('Requires Python @0@, @1@ found.'.format(python_version_req, python_version))
+endif
+
cc = meson.get_compiler('c')
config = configuration_data()
config.set_quoted('GIR_SUFFIX', 'gir-1.0')