summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2010-11-11 09:54:35 -0500
committerColin Walters <walters@verbum.org>2010-11-11 09:54:35 -0500
commit270677b2a8bbea473bb0904df35bab6340758bb9 (patch)
tree0c0f7a6ca361241dadefe7778b2afe5224294f18 /tests/Makefile.am
parent84608743897ef60071757c09216f60f8861f504e (diff)
downloadgobject-introspection-270677b2a8bbea473bb0904df35bab6340758bb9.tar.gz
build: Fix scanner/compiler to look in $(top_builddir) now
Since we're nonrecursive, the build artifacts live in $(top_builddir), so look there now for files like Gio-2.0.gir.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2c4c5475..32c3522c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -47,7 +47,7 @@ Everything-1.0.gir: libeverything-1.0.la Makefile
$(AM_V_GEN) $(INTROSPECTION_SCANNER) $(INTROSPECTION_SCANNER_ARGS) --warn-all --warn-error --reparse-validate \
--namespace=Everything --nsversion=1.0 \
--libtool="$(LIBTOOL)" \
- --add-include-path=$(top_builddir)/gir --include=Gio-2.0 \
+ --add-include-path=$(top_builddir) --include=Gio-2.0 \
--library=libeverything-1.0.la --output=$@ \
everything.h everything.c
@@ -55,7 +55,7 @@ GIMarshallingTests-1.0.gir: libgimarshallingtests-1.0.la Makefile
$(AM_V_GEN) $(INTROSPECTION_SCANNER) $(INTROSPECTION_SCANNER_ARGS) --warn-all --warn-error --reparse-validate \
--namespace=GIMarshallingTests --symbol-prefix=gi_marshalling_tests --nsversion=1.0 \
--libtool="$(LIBTOOL)" \
- --add-include-path=$(top_builddir)/gir --include=Gio-2.0 \
+ --add-include-path=$(top_builddir) --include=Gio-2.0 \
--library=libgimarshallingtests-1.0.la --output=$@ \
$(srcdir)/gimarshallingtests.h $(srcdir)/gimarshallingtests.c