summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2010-07-31 06:56:09 -0400
committerColin Walters <walters@verbum.org>2010-08-31 16:05:56 -0400
commit456a79cb1d3fee93a3e6e1af9ef2948b0866bdd3 (patch)
tree39ae1a74a788b04dcdd9662aa3e819f034b9bd7c /tests/Makefile.am
parent5db39d8c88d8bb09ea4a8968a78e5d49e2165a5a (diff)
downloadgobject-introspection-456a79cb1d3fee93a3e6e1af9ef2948b0866bdd3.tar.gz
tests: Remove GIMarshallingTests, rename Everything to Regress
GIMarshallingTests will be replaced with automatically generated code; it was far from comprehensive, and was a pain to maintain. The namespacing in Everything was broken; it had an empty C prefix effectively, because all the symbols just started with "test". We do want "test" as part of the symbols, since otherwise the exported API would be weird. Fix this by changing the namespace to Regress (i.e. prefixing all the C code with Regress). This makes sense anyways because Everything wasn't really Everything. We no longer install a pre-built regress.(so,gir,typelib); instead we install the C code to $(datadir)/gobject-introspection/tests/regress.[ch]. Bindings should compile this.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0c51358a..a86a750f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1 +1,35 @@
SUBDIRS = . scanner repository offsets
+
+BUILT_SOURCES=
+CLEANFILES=
+
+INCLUDES = $(GOBJECT_CFLAGS)
+LIBADD = $(GOBJECT_LIBS)
+
+noinst_LTLIBRARIES = libeverything-1.0.la
+
+libeverything_1_0_la_SOURCES = everything.c
+
+BUILT_SOURCES += everything.c everything.h
+
+CLEANFILES += $(BUILT_SOURCES) everything-stamp.h
+everything-stamp.h: Makefile
+ $(AM_V_GEN) $(top_builddir)/tools/g-ir-scanner --test-codegen=Everything,everything.h,everything.c
+ touch $@
+
+everything.c: everything-stamp.h
+ @true
+
+everything.h: everything-stamp.h
+ @true
+
+Everything-1.0.gir: libeverything-1.0.la
+ $(AM_V_GEN) $(top_builddir)/tools/g-ir-scanner --warn-all --reparse-validate --namespace=Everything --version=1.0 --library=libeverything-1.0.la everything.h everything.c --output=$@
+
+Everything-1.0.typelib: Everything-1.0.gir
+ $(AM_V_GEN) $(top_builddir)/tools/g-ir-compiler $< -o $@
+
+install-data-local:
+ for src in everything.c everything.h; do \
+ install -m 644 -D $$src $(datadir)/gobject-introspection-1.0/tests/$$src; \
+ done