summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@gnome.org>2008-08-14 11:23:26 +0000
committerJohan Dahlin <johan@src.gnome.org>2008-08-14 11:23:26 +0000
commit2f24c447fbe50c83a60deb523108b62805c2714f (patch)
tree9e648a8726fc6e3ec3a01b6d1fcbf6a432a9d23a /tests/Makefile.am
parent4a235bd178226ed010c7290321b1df6d2e6cdc85 (diff)
downloadgobject-introspection-2f24c447fbe50c83a60deb523108b62805c2714f.tar.gz
Add pyflakes.py and run it in make check. Update the source code to fix
2008-08-14 Johan Dahlin <johan@gnome.org> * giscanner/girwriter.py: * giscanner/glibast.py: * giscanner/glibtransformer.py: * giscanner/transformer.py: * misc/pyflakes.py: * tests/Makefile.am: Add pyflakes.py and run it in make check. Update the source code to fix the errors reported by pyflakes. svn path=/trunk/; revision=370
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f903af02..5ddcc522 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,4 +20,7 @@ EXTRA_DIST = \
TESTS = #roundtrips.sh
check-local:
- find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat
+ @echo Running PEP8 on Python sources
+ @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat
+ @echo Running Pyflakes on Python sources
+ @find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pyflakes.py