summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTommi Komulainen <tommi.komulainen@iki.fi>2008-10-15 22:08:53 +0000
committerTommi Komulainen <tko@src.gnome.org>2008-10-15 22:08:53 +0000
commit5d618a4421a83234a7b29853a04647135731d296 (patch)
tree0c5c1da931b1e3373ccbd358ef1d3a668bc5c760 /tests/Makefile.am
parent6ce16402c5d668049a6908914cb42965840d3abd (diff)
downloadgobject-introspection-5d618a4421a83234a7b29853a04647135731d296.tar.gz
fix tests to compare xml to xml instead of typelib to xml, and stop on
2008-10-15 Tommi Komulainen <tommi.komulainen@iki.fi> * tests/Makefile.am: fix tests to compare xml to xml instead of typelib to xml, and stop on error svn path=/trunk/; revision=719
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6f7fdb48..f5cbed35 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -22,11 +22,13 @@ GIRTESTS = \
object.gir.test \
struct.gir.test
+CLEANFILES = $(GIRTESTS:%.gir.test=%.1) $(GIRTESTS:%.gir.test=%.2)
+
%.gir.test: %.gir Makefile
@echo Testing $<:
- $(DEBUG) $(top_builddir)/tools/g-ir-compiler --includedir=$(top_builddir)/gir $< > $*.1; \
- $(DEBUG) $(top_builddir)/tools/g-ir-generate --includedir=$(top_builddir)/gir $*.1 > $*.2; \
- diff -u $*.1 $*.2; rm $*.1 $*.2
+ $(DEBUG) $(top_builddir)/tools/g-ir-compiler --includedir=$(top_builddir)/gir $< > $*.1
+ $(DEBUG) $(top_builddir)/tools/g-ir-generate --includedir=$(top_builddir)/gir $*.1 > $*.2
+ diff -u $*.gir $*.2 && rm $*.1 $*.2
check-local: $(GIRTESTS)