summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMark Doffman <mark.doffman@codethink.co.uk>2008-02-28 00:37:01 +0000
committerRobert James Taylor <robtaylor@src.gnome.org>2008-02-28 00:37:01 +0000
commit8eb3279f8de9f384c7c832577cd07e9683cac8c6 (patch)
treed00fc9c40dca766791967e74fa04424a6870b499 /tests/Makefile.am
parent527a5908021d35a97c5ff70be490df1e644ed43b (diff)
downloadgobject-introspection-8eb3279f8de9f384c7c832577cd07e9683cac8c6.tar.gz
reviewed by: Rob Taylor <rob.taylor@codethink.co.uk> reviewed by: Johan
2008-02-21 Mark Doffman <mark.doffman@codethink.co.uk> reviewed by: Rob Taylor <rob.taylor@codethink.co.uk> reviewed by: Johan Dahlin <johan@gnome.org> * tests/Makefile.am: * tests/roundtrips.sh: Modify the roundtrips test so that they do not use the --raw option of the gidl compiler but instead compile a shared library to use with g_module. * tests/invoke/Makefile.am: * tests/invoke/invoke.c: Modify the invoke tests to build a shared library rather than use the --raw option. * tests/invoke/invoke-namespace-find.sh: Removed: Noone knows why this was here, so removed. svn path=/trunk/; revision=120
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7dc01659..86344828 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,9 +1,10 @@
-SUBDIRS = . invoke parser
+SUBDIRS = invoke parser
EXTRA_DIST = \
roundtrips.sh \
array.test \
boxed.test \
+ constant.test \
enum.test \
errors.test \
function.test \
@@ -11,8 +12,16 @@ EXTRA_DIST = \
interface.test \
object.test \
struct.test \
+ types.test \
union.test \
xref1.test \
xref2.test
+TESTS_ENVIRONMENT = \
+ LIBTOOL="$(LIBTOOL)" \
+ GIREPO_CFLAGS="$(GIREPO_CFLAGS)" \
+ GIREPO_LIBS="$(GIREPO_LIBS)" \
+ CC="$(CC)" \
+ GIREPOPATH="."
+
TESTS = roundtrips.sh